M Lineage 1.0

Redefining the role of visualization in pedigree analysis

Getting Started

Importing Data:

Pedigree data files for use with Lineage need to be of a somewhat specific format. The files need
to be ascii text files (filename.txt) or a comma separated values file (filename.csv) of the type
exported by programs such as Microsoft Excel. The guidelines for the pedigree files are as follows.

1. The following columns are required in every input file, in this order, separated by commas: ID,
Dam, Sire, Sex.

2. Sex can be entered as "male" or "female," "m" or "f" or as a number coded as 0 = Male and 1
= Female.

3. If anindividual has unknown parents, the field can be left blank or coded as unknown. If an
unknown code is entered in fields for individuals with unknown parents, that code needs to be
identified during project creation. This is detailed in the project creation section.

4. Any number of extra data columns can be added in any order after the required four data
fields, separated by commas again. Just be sure that they are identified in the column
headers or the field will be excluded when the file is processed.

5. The files can contain comments (not imported as data) on any line beginning with the pound

character (“#”). Note that no data following this character on any one line will be read in.

The file must contain column headers as the first line of data.

No text qualifiers (such as quotation marks) should be used on string data.

Boolean data can be represented by the letters T and F, 1 and 0O, or by the words true and

false. Case is irrelevant.
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The following is an example of proper format for a pedigree file with three individuals:
#Comments....

ID, Dam, Sire, Sex, Trait 1, Trait 2

Animal 1, , , 1, true, true

Animal 2, , , O, true, false

Animal 3, Animal 1, Animal 2, 0, true, true

An easy way of creating a file of the proper format is to create a .csv file using Microsoft Excel.

First create a spreadsheet with the appropriate columns in the correct order and with column
headers. Next from the file menu choose “Save As.” In the pull down menu for the file type choose
the type “CSV (Comma Delimited).” When you save the file you will be prompted that saving the
file in this format will lose some data, this is OK, so click “Yes” to create the .csv file.

Creating a New project:

Click “New Project” from the opening screen of Lineage. At the screen for Step 1, type in a name



for your new project in the “Project Name” text field. Note that a default folder and location will be
identified for your project, but you can change this by typing in a new location or clicking Browse
next to the “Project Folder” field. In the field marked “Input File,” type in the name of the txt or csv
file containing a properly formatted pedigree data, or click the Browse button to the right of this field
to search for a file. At this point, you also have the option of creating a pedigree by hand. To do
so, choose the option to enter a pedigree by hand (more information on this below). Click the Next
button to continue.

At the Step 2 screen, you will be asked to specify the types of data included in the additional data
columns in your pedigree. You can certainly leave all of the fields as the default “String” type, but
you will be missing out on much of the functionality of some of the tools of the program. Click on

the field for data type for each of the fields that you wish to change. A combo box will appear that
allows you to choose the type of data to import. Click Next to continue.

At the screen for Step 3, you are given the final options for building your new project. You can
enter the ID of an individual or a list of ID’s of individuals (separated by commas) in the box marked
“‘Individual ID’s” if you wish to work only with the pedigrees of certain individuals within the pedigree
file. This can be particularly helpful with very large input files. If you choose to do this and have the
“Include relatives” box checked, you will be given options as to which relatives of the individuals in
the list you wish to include in your analyses. By clicking the “Advanced Options” button, you can
see some other options for importing your data. The majority of these are data checks that can be
turned on or off. Here you are also given the option of specifying what codes might be used in the
pedigree file to represent that an individual has an unknown parent. You can include any number
of identifiers; separate the list by commas. Click Finish to build your new project.

Creating a Pedigree by Hand:

You have two options for entering a pedigree by hand: using the table view or the graphic view.
The two can be used interchangeably; any changes or additions you make using one view will
persist in the other view when you switch back and forth using the tabs. The most efficient way of
using this tool is probably to enter the pedigree using the graphic view and then switch over to the
table view to enter data for each of the individuals.

In the table view, enter new individuals in the column marked ID, and enter the individual's damn,
sire, and sex in the appropriate columns in that individual's row. To enter more individuals when
there are no rows remaining in the table, either type an ID into the bottom row that is marked with a
“+” and hit enter or click the Add Individual button. You can remove an individual by selecting that
individual's row and clicking Remove Individual.

To add a data column using the table view, click the Add Data button and then enter a name for the
new column. The column will be created as the right-most column of the table and be empty. You
can create as many columns as you like. You can remove a column by clicking the Remove Data
button and then selecting to remove the columns of your choice from the list that will be presented
to you.

Using the graphic view is slightly more complicated but is actually a much quicker way to enter a
pedigree. To enter the pedigree of a single individual, enter the individual's ID in the left-most text
box, then enter that individual's parents, grandparents, etc., in the boxes to the right. To extend the
pedigree beyond the number of generations displayed in the window, you can either click on the
individual's name in the list beneath the left-most box to bring that individual into the left-most box,
or you can click the button to the right of the individual's box with the tool tip text “Set this individual



as the left-most entry.” You can make any individual the left-most entry in this fashion.

If you type an individual's ID into a box and that individual already has been entered, all of that
individual's ancestors will automatically be filled in to the right providing there is no conflict as far as
sex or relationships.

Using the buttons underneath the individual list, you can either delete an individual from the
pedigree, clear the boxes to make room for entering a new individual, or enter siblings for the
individual in the left-most box. The Sibs button is useful in that it allows you to enter a group of
siblings without having to type in the parents' names for each of the siblings.

You can enter data for individuals by clicking the information button to the right of a box for any
individual. Here you will have the ability to add a column of data, remove a column, or change the
data for any individual. Note that if you add or remove a column of data from this data dialog, it is
for all individuals, not just the one you are currently working with.

When you are finished creating the pedigree, you can access the same advanced options for
creating a project that you normally can by clicking the Advanced Options button in the bottom left
corner of the window. Click Finish when done to proceed.

Using the Toolbox Tools

Toolbox:

The toolbox is a floating tool palette that gives you access to all of the important visualization and
manipulation tools in Lineage. A brief description for the use of a tool will pop up when the cursor
is held over the icon for that tools. Any of the tools in the toolbox can also be accessed via the
Tools menu. You can choose to hide the toolbox (NOTE: if you do not hide the toolbox while
exporting a picture of your pedigree, the toolbox may show up in the picture) and can always show
it again by selecting the menu Tools > Show Toolbox. A description of all of the tools follows.

Standard Pointer

This tool is used by default. This tool has no special properties so it should be used when you want
to view the current Pedigree with no extra visualization tools.

Selection Tool

This tool has a few different uses including selecting all animals in a rectangle, moving all animals
in a rectangle, or zooming into a rectangular section of the pedigree. Whatever the purpose, the
first step is always to draw a rectangle on the current pedigree. To do this, click and hold the left
mouse button where you want one corner of your rectangle to be. Move the mouse until the
rectangle expands to the location that you would like, and then release the left mouse button. After
this, you have a few different options:

e Zooming into a rectangular location: Select the Zoom tool and then click on the rectangle
that you just drew. This will zoom you in so that the center area shows only the part of the
pedigree that was in your rectangle. This can be very useful if you have a very precise area
that you want to look at.



e Moving all animals contained in the rectangle: Select the Repositioning tool and then click
and hold the left mouse button. Now drag the mouse a small distance away from its original
location and then release the left mouse button. (Note: Be careful not to try to move the
animals too far because if you attempt to move any animal either above one of its parent or
below any of its children, then the entire action will be cancelled.)

e Selecting/disabling all animals contained in the rectangle: Click on the rectangle. You
will have options to change the status of the selection or enabled status of all of the animals
in the rectangle and to select all animals that are related to any animals inside the rectangle.

Zoom Tool

This tool lets you zoom in or out of the current pedigree. Often when looking at large pedigrees,
you will want to look more closely at certain portions of the pedigree, or if you are already zoomed
in, you may want to zoom out a little bit to expand the view. Zooming in can be especially
important when you have decided to draw information onto a pedigree because this graphical
information can only be viewed when you are sufficiently zoomed in so that each animal's graphic
is more then a few pixels (for large pedigrees, this might require a fair amount of zooming, whereas
with smaller pedigrees, each animal's graphic may already be of sufficient size).

To zoom in, select the Zoom tool and then click the right mouse button over the area that you want
to look more closely at. If you hold down the CTRL button, then mouse should change from having
a "+" in the magnifying glass to a "-." Now if you click the left mouse button, you will zoom out.

You can also zoom using the combo box labeled Zoom located at the top left of the Lineage
window. You can scroll for choices or type in your own level of magnification (%) and then click the
Zoom button. Clicking Standard View at any time will return you to the original level of
magnification and center the view.

Note: After zooming in, you may use the arrow keys or the Grab and Move tool to move around the
current pedigree.

Note: If you zoom in past the standard view, you should see a red rectangle over the very small
picture of the pedigree in the lower right. This rectangle represents the current portion of the
pedigree that is being displayed.

Magnifying Tool

This tool lets you see a small window of a higher magnification of the current pedigree, while
maintaining the current magnification of the larger window. This is ideal if you want to browse
some information quickly at a higher magnification level.

To use this tool, click and hold the left mouse button. You will see a smaller window appear over
your mouse, and as you drag the mouse while holding down the left mouse button, this window
moves around with your mouse. This simulates moving a magnifying glass over a picture.

Grab and Move Tool
This tool lets you move the pedigree around after you have zoomed in farther than the standard
view. To use this tool, click and hold the left mouse button on the pedigree window and move the

mouse to move in any direction.

Note: You can also use the arrow keys to move around in much the same way without using this



tool.

Note: Since you must be zoomed in past the standard view to use this tool, you will see a red
rectangle over the very small picture of the pedigree in the lower right. As you move the pedigree
around, you will see the red rectangle move around accordingly.

Relative Finder Tool

This tool lets you view and manipulate relatives of individuals. When you click on this tool, a
window will appear that asks you to choose some options as to which relatives you want to
manipulate. The default is to manipulate all ancestors and only ancestors. Once you click on OK,
you can move the mouse around without clicking any buttons, and whenever the tool is placed over
an individual, the appropriate relatives of that individual are immediately outlined.

Now while using this tool, you can click the left mouse button, and all of the appropriate relatives
are then highlighted. There are then steps you can take to manipulate the currently highlighted
animals (such as creating a subset of only highlighted animals).

Relationship Tool

This tool lets you find the additive genetic relationship of two animals. After you click on the tool, a
window will appear with two spaces to enter animal names into. Type a valid name into each and

then click "Find." The result will be calculated and displayed. To get the names of individuals, you
can also right click on an individual, and choose the “Copy Individual's Name” menu option. Then

you can paste the name into the box by right clicking or pressing Ctrl-V in the box.

If the individuals you select are of the opposite sex, a note will appear showing what the coefficient
of inbreeding (F) would be for an offspring produced by the mating of the two individuals.

Repositioning Tool
This tool lets you reposition an animal within the pedigree.

Note: Animals can only be assigned specific coordinates within the grid. If you attempt to
reposition an animal and the animal doesn't move at all, you may have not moved the animal far
enough to be assigned a new grid location. You can draw the grid on the pedigree to overcome
this problem.

Note: Be careful not to try to move an animal too far because if you attempt to move an animal
either above one of its parent or below any of its children, then the action will be canceled.

Inbreeding Tool

This tool lets you quickly get the inbreeding coefficient of an animal. After you click on the tool, a
window will appear that tells you to click on an animal. After you click on an animal, the animal's
inbreeding coefficient will be displayed in the window.

Labeling Tool

This tool lets you view ID’s of individuals in very dense pedigrees. After you click on the tool, a
circle will be drawn around the mouse. As you move the mouse around without pressing any
buttons, information should be displayed for animals that are inside of the circle (with a maximum



of 10 animals on each side of the circle). This is useful when information is too long to display for
every animal.

Managing Data
Adding/Deleting Data Columns:

To add an additional column of data for your project, choose the menu option Data>Add Column.
A dialog will present you with options for the name of the new column, the type of data to be
included in the new column, and what the default value for data in that column should be. If you
are currently working in a subset, you will be given the option of adding a new boolean (true/false)
column, in which members of the current subset will be marked as true and all others will be
marked as false. There are many potential uses of this option.

To delete a column of data, choose the menu option Data>Delete Column. You will be given a list
of all of the columns of data in your project and the opportunity to delete any of these. Remember
that deleting a column is a permanent action; there is no way to recover the data (if the column you
deleted was imported with the original data, you could create another new project to have access
to those data).

Individual Data:

Every individual in the population has an associated data sheet that contains information on its
parents, progeny, coefficient of inbreeding, and data values in all the columns of data in your
project. You can access the data sheet for any individual by right clicking on that individual's node
in the drawing window and choosing the menu option Get Individual Data. The default panel in the
data window is this data sheet, and data can be copied from here for pasting into other
applications, etc. Choosing the tab marked Edit Data will allow you to change the values for data in
any of the columns. You will only be permitted to change data to values of the appropriate type, of
course. You are also not able to change values for sex, parents, etc., in this version of Lineage.

Population Statistics:

There is a panel at the bottom of the Lineage screen that contains simple population information for
the current population in your project. Information on the initially imported population (Total
Population) is always displayed. You can see the number of individuals in the population (N) as
well as the mean inbreeding (mean F). If you are working in a subset, the population statistics for
that subset will also appear. Likewise, if you have a group of individuals selected, this information
panel will also tell you the number of individuals included in the selection and the mean F of the
selection.

Inbreeding:

In all populations of fewer than 5000 individuals, coefficients of inbreeding (F) are calculated for all
individuals (calculating F for all individuals in large populations is not the default as it could be a
lengthy process on some older systems). You can see the value of F for any individual by moving
the cursor over the node for that individual and looking at the bottom of the Lineage window. You
could also use the Inbreeding Tool. If your population is larger than 5000 individuals, you have a



few options if you are still interested in looking at inbreeding values or population mean inbreeding.

e To go ahead and generate F values for the entire population, choose the menu option
Data>Calculate Inbreeding For All Individuals. This will compute F for all individuals in the
population and the mean inbreeding for the population. Be aware that this could take some
time for very large populations or on older systems.

o Create a subset, and then choose the same menu option. It will not take nearly as long to
compute F for all individuals with reduced population size. Note: if you choose this option
while working with a subset, F will be calculated based only on the relationships found in this
subset. This is a good way to speed up inbreeding calculations, but be sure that you have all
of the important relatives included in the subset to generate accurate values of F.

e Use the Inbreeding Tool and click on any individual. If F has not been calculated in your
population, values for F will be calculated on the fly for that individual and all of its ancestors.
Those values will be remembered and not recomputed the next time. While this will not show
you the mean F for the population, it is the fastest option.

Vertical Positioning of Nodes:

The vertical positioning of the individual's nodes in the pedigree drawing (could also be referred to
as generation) is based on the number of ancestors that any individual is removed from the
founders by default. If you have other data that you wish to use to determine the vertical
positioning of the individuals, choose the menu option Data>Set Vertical Positioning of Nodes.
You will be given a list of the possible columns of data that could be used to determine vertical
position. The guidelines for this are that the column must be of type Integer or Date, and all
individuals must have a higher value in this column than that of both of their parents. You can then
choose from these columns to position the nodes or choose the default option. This can be
changed or reset at any time. This can be used to arrange individuals by birth date or by
generation if you have an independent means of assigning generations to individuals.

Pruning:

By choosing the menu option Data>Prune Pedigree, you will be given two options and their
descriptions for reducing the size of your pedigree. Choose this option for large pedigrees or in
cases where you want to analyze only contributing members of a population. When you choose to
prune the pedigree, the individuals that have been pruned become disabled. To create a subset
excluding the pruned individuals, click the Subset button or choose the menu option Subsets>New
Subset From Selection or All Enabled.

Drawing on the Pedigree

Drawing in Lineage refers to coloring in individuals' nodes based on their values in certain data
fields or to show their breed composition. It is an entirely different concept from selection and
disabling. It can be used in conjunction with selections or disabling, but for nothing more than
visual or conceptual assistance.

Drawing Data on the Pedigree:



Click the menu choice Drawing>Draw Data On Pedigree. When choosing this, you will be given
options for coloring individuals' nodes based on the columns of data in your project. There are two
choices here, with a tab for each:

Multiple Data Fields

This tab lets you draw data onto the pedigree from across multiple columns in your pedigree data.
For example, you could have it color individuals with blue eyes blue and blonde hair yellow, and an
individual with blue eyes and blonde hair would then be shown as half blue and half yellow. This
can be helpful in identifying interactions or relationships between traits or between any of the
columns of data that you have imported or created.

To draw, first check the boxes of the data fields that you wish to color onto the pedigree. Then
click the corresponding color swatch if you wish to change the color to represent that data field.
Next, just like in Selecting By Data, set the comparison method and the target value for that field.
Clicking Draw will color in all individuals that meet the criteria you have specified.

Single Data Field

This tab lets you fill in each individual's node with a single color, based on what its value is for one
data field that you choose. First, from the list at left select which of the data fields you wish to work
with. Next, depending on the data contained in the field you choose, you will have one or two
choices for how to represent the data:

e Draw based on discrete data values: This option is available when there is a small number of
different values appearing in the field you have selected. For example, a field representing
phenotype for eye color might only have a few values. The data are considered to be
discrete. Choose colors for each of the values in the column and click Draw. Each individual
with data in this field will be wholly filled in with the color corresponding to its value in this
field.

e Draw based on continuous data: If the data field you choose is numeric and has a large
number of different values across the population, you will have the option to represent this
continuous data with a gradient. Set the minimum and maximum data values in the boxes
provided. These values are the values at which an individual will be colored with the pure
minimum or maximum color, which you can set by clicking on the appropriate color swatch.
Individuals with any intermediate data value will be colored according to the sample gradient
drawn below.

Drawing Breed Fractions on the Pedigree:

Drawing breed fractions is similar to drawing data on the pedigree, but there are some notable
differences. When you choose to draw breed fractions on a pedigree, only data for founders are
considered. Lineage then computes the breed fractions of all descendents of these founders
based on their initial breed compositions and colors in all individuals accordingly.

Data for breed composition of founders can be in two formats. The first is where all of the founders
are known to be or are assumed to be purebred. There would be a single column of data in your
pedigree of the String type, and each of the founders would have the name of the breed as its
value in this field. This is referred to as Breed Data From A Single Column. The second possibility
is that the founders are not purebred. In this case, there would need to be a column of data for
each of the possible breeds and then the founders composition of each of the breeds. This



composition could be represented as either a decimal value (0 to 1) or a percentage (0 to 100).
This method is referred to as Breed Data From Multiple Columns.

Breed Data from a Single Column

On this tab, simply choose the data field that contains your breed data from the list at left. You can
change the color representing each breed at this time if you like. Then click Draw to draw the
fractions onto the pedigree.

Breed Data from Multiple Columns

In this tab, check the boxes in the row of the data fields that contain your breed composition data.
You can also set the colors that represent each breed at this time. Before clicking Draw, look at the
check box underneath the list of data fields. If your data are decimal representations between 0
and 1, be sure this box is NOT checked. If they are percentage data between 0 and 100, then
check it before continuing.

Legend Panel:

Whenever you are drawing data on the pedigree, you have access to the Legend Panel. When you
first draw on the pedigree, it will be shown at right by default. You can hide it and retrieve it at any
time by choosing the menu option Drawing>Show Legend Panel. The Legend Panel shows you a
table with the colors and criteria for your drawing. In this table, you have the option of changing the
colors or in some cases checking or unchecking the boxes for drawing certain data fields. If you
make changes in this table and wish for them to be updated in the drawing window, click Apply.
Clicking Modify will take you back to the appropriate drawing options window.

Drawing a Legend on the Pedigree:

Clicking the menu choice Drawing>Draw Legend On Pedigree will place a legend directly into the
drawing window. This is helpful if you plan on printing or saving an image of your pedigree. You
can move the legend around on the pedigee by left clicking and dragging it to a new location.
When you have drawn a legend on the pedigree, you will notice that the menu option for it now has
a check mark next to it. If you select that menu choice again, it will hide the legend.

Clearing Drawing:

To clear all of the coloring from nodes, choose the menu option Drawing>Clear Drawn Data. You
can also click the Clear button located in the Legend Panel.

Selection and Selecting

Selections in Lineage are used mainly for the purpose of taking subsets. Individuals who are
selected appear in the drawing window with a yellow highlight around their respective nodes.
Selections can be generated by combining various selection methods as well. Individuals can be
selected and deselected in the following ways:

Right Clicking



Right clicking on an individual gives you the option to select or deselect that single individual. If a
selection rectangle is drawn, this will select or deselect all of the individuals within that rectangle.
From this right click menu, you will also be given the opportunity to select or deselect that individual
and all of its relatives. When choosing either of these options, you will be presented with options
for which relatives to include.

Selecting by Sex

By choosing the menu option Selection>Select All Males or Selection>Select All Females, you can
select all of the members of one sex in the pedigree.

Selecting Individuals Based on Column Data

You can select individuals based on their values in the columns of data for your project by
choosing the menu option Selection>Select Individuals By Data. A window will pop up that lets you
choose which column(s) you wish to base your selection on. First check the box to the left of the
column(s) you wish to select. Next, choose the target value that you wish the selection to be
based on. Click on the cell in the table in the value column corresponding to the appropriate data
field and type in a new value. Then choose the means of comparison by clicking on the value in
the column marked If. A pull-down menu will give you options for =, >, <, etc.

If you have more than one column selected, you have the option to select all of the individuals that
meet any of the criteria you have chosen (a union of the selections) or only those individuals that
meet all of the criteria defined (the intersection of the selections).

Select Individuals by Inbreeding

You can select individuals based on their coefficient of inbreeding by selecting the menu option
Selection>Select Individuals by Inbreeding. A window will pop up in which you can set the method
of comparison (=, >, <, etc.) and the target value of inbreeding that you wish to compare against. If
you wish to include the relatives of the individuals that meet your criteria for selection in the
selection you are generating, click the box marked Include Relatives.

Select Individuals by Number of Progeny

You can select individuals based on their number of progeny by selecting the menu option
Selection>Select Individuals by Number of Progeny. A window will pop up in which you can set the
method of comparison (=, >, <, etc.) and the target value of number of progeny that you wish to
compare against--the same way you would do for inbreeding. If you wish to include the relatives of
the individuals that meet your criteria in the selection you are generating, click the box marked
Include Relatives.

Selecting Relatives of Selected Individuals

You can add relatives of the individuals currently selected to your selection by choosing the menu
option Selection>Select Relatives of Selected. You will be given the standard options window for
choosing which relatives to include in your selection. Note: if you use this method after selecting
by data, inbreeding, or progeny and then immediately create a subset, the originally selected
individuals will carry over and be selected in the subset that you create.

Inverse Selections



You can invert your current selection (all individuals that are not currently selected will become
selected while the currently selected ones will be deselected) by choosing the menu option
Selection>Select Inverse.

Finding an Individual

You can quickly find one individual in the population and select it by typing its ID into the combo box
marked Find in the top right corner of the Lineage window and clicking Find. Lineage will
remember the names of individuals that you have typed in this box. If you don’t know the full ID of
an individual, or wish to see or select a group of individuals whose ID’s begin with the same
characters, you can type in the first part of the ID and click Find to see a list of partial matches.

You will have the option of selecting one, some, all, or none of these matches.

Clearing Selections

You can clear the current selection at any time by choosing the menu option Selection>Clear
Selection or by clicking the Clear button next to the Find box at the top right corner of the Lineage
window.

Disabling

There may be times when you want to work with only certain individuals within the population or a
subset but do not wish to create a subset. For example, you may wish to work with one family
within a population but at the same time see any relationships that may exist among the members
of that family and other individuals in the population. Individuals that are disabled still count toward
population statistics, but they cannot be selected or added to any selection that you are
generating. For these times, you have a few options for enabling and disabling individuals in the
population.

Right Clicking

As with selecting, there are options for enabling and disabling individuals available to you when you
right click on an individual's node or within a selection rectangle. You will simply have the option to
enable or disable a single individual or, if you are clicking in a selection rectangle, all of the
individuals contained within that rectangle.

Disable by Sex

By choosing the menu options Disabling>Disable All Males or Disabling>Disable All Females, you
can disable all individuals of a certain sex.

Disabling Based on the Selection

By choosing the menu options Disabling>Disable All Selected or Disabling>Disable All Not
Selected, you can either disable all of the individuals that are currently selected (also deselecting
them as disabled nodes cannot be selected) or disabling all of the individuals that are not members
of the current selection.

Enabling Individuals



You can return individuals to being enabled either through right clicking on their nodes or by
choosing the menu option Disabling>Enable All Individuals. The latter will return every member of
the current population to an enabled state.

Data Sets and Subsets

Perhaps the best way to deal with large amounts of pedigree data is through breaking the
population up into more usable subsets. Lineage makes it easy to subset your population quickly
and then navigate through and toggle between subsets.

Creating Subsets:

Creating a subset is simple. Make a selection or disable a portion of the population. Whichever
individuals are selected or remain enabled will become your new subset. If some individuals are
disabled and no individuals are selected, the entirety of the enabled population will make up the
new subset. However, if even one individual is selected, the subset will be composed of only those
individuals that were selected.

To create the subset, either choose the menu option Subsets>New Subset from Selection or All
Enabled or click on the button just to the right of the word “Subsets” in the top-center of the
Lineage window (tf you hold the cursor over this button for a few seconds, the tool tip text will
identify it as the button to create a new subset). You will be presented with a dialog asking you to
enter a name for your new subset. It will also show you a list of the names of all existing data sets
or subsets for your reference.

Managing and Moving between Subsets:

There are two ways to move between subsets in Lineage. There are menu choices Subsets>Up
One Level and Subsets>Top Most Level that move you either up to the parent data set of the
subset you are currently viewing or to the top-most data set, which is the data set that you
imported when creating the project. There are also quick buttons corresponding to these menu
options located next to the quick button for creating a subset, in the top-center of the Lineage
window.

The other method for navigating your subsets is with the Data Set Manager. To access this, click
either the menu choice Subsets>Data Set Manager or the quick button that looks like a tree view
list to the right of the other quick buttons for subsets. From the Data Set Manager you can take a
quick look at each of your subsets in its preview pane. You also have three commands available
to you from here:

e Merge: Clicking the merge button while any subset is selected will bring up a window that will
give you various options for merging the subset you chose with any of the other subsets.
Select a subset from the list of available sets in the merge window, choose the method to use
for the merge, and then merge them. A new subset will be created as a result.

e Delete: Deletes the selected subset and all of its child subsets. This is permanent—deleted
subsets cannot be recovered.

e [oad: Loads the selected subset into the main drawing window in Lineage.



Saving and Opening Projects

Saving and opening projects works like in most other Windows applications. To save a project, use
the File>Save and File>Save As menu options. Projects will be saved with a number of temporary
files and a filename.pvf file. Itis important that you do not delete any of the files found in the
project folder that you specify when you first create the project. Doing so will result in your project
file failing to open at a later time. Once you save a project that you have created, it is completely
detached from the pedigree file that you imported.

To open a saved project, choose Open an Existing Project when first opening Lineage. You can
also access the open project dialog from the File>Open Project Dialog.

Exporting Data

You can export the data from your project into other Windows applications in two forms. First, you
can export a comma delimited text file of your pedigree and all of its data columns. The file will be
of type filename.txt. The other method is to export a picture of your drawing window as a Bitmap
file (filename.bmp). The file that is created is an exact recreation of the drawing window and is
produced at the same size as your current drawing window. Note: Currently it is recommended
that you hide the tool palette when using this feature, as on some systems the toolbox will be
included in the picture. To access these, go to the File>Export Dataset To> menus.

Options

There are a number of options for coloring, label placement, etc. available through the
Tools>Options menu choice.



